Oh what a wonderful weekend it was...

This last weekend was quite exciting, made some major progress on building our new deck, but this post isn’t really about that, I’ll have a whole separate post with pictures, timelapse, etc… once it is done.  This post is about watercooled PCs and what happens when they fail!

So, sometime between Friday night and Saturday morning, my watercooler failed.  The outlet on the pump (all in one type unit so the pump was on the CPU heatsink) broke off, not really sure how, and sprayed a water/glycol (I think?) all over the inside of my machine.  My heart sank a bit as the machine was still ‘on’ but unresponsive and it took me a minute to figure out what happened before removing the power.  Once I figured it out I pulled the machine into the garage.

I started tearing into it, literally did a full disassembly on my computer, and let it dry for 2 days before even attempting to use any of the parts.  This was mainly because I was quite busy with the deck, but it was good as I was not tempted to put it back together prematurely.

After 2 days I got out the IPA and some q-tips and started cleaning up the remaining glycol and any other mess.  It took a few hours to get everything as clean as I wanted.  I waited several more hours after cleaning to insure they were as dry as possible.  Then came the time, what was broke?  Just from the outside looks, the GPU closest to the waterblock looked in bad shape, so I decided to switch the two, in case that one didn’t work, less fumbling later.

I started putting it all back together, got a new cooler (yes still liquid, I’ve been doing liquid cooling for years, one mishap sucks but I really like the quiet running) and tossed it all back together.  Hooked it up in the garage, hit the power button, and after a few seconds I hear that wonderful, singular POST beep.  My spirits uplifted I pressed on.

I took a few minutes and tweaked the BIOS so it was more or less like it was before, rebooted it again, still good… Then I let it boot up into Windows, and it went through some ‘Uh Oh!’ problems, and then finally started to really boot!  And then gave me a nice shiny BSOD, indicating an nvdllsys or something failure, it was pretty obvious that it was an Nvidia driver error, and looking at the cards, all the lights had gone out on the card that took the big hit.

I removed the card and of course it booted without issue.  Damn.  I took the card apart, down to the bare board to try and salvage it with more cleaning, hoping I had missed something that might stir it back to life.  But alas it was not meant to be.  So I now how a GTX 980TI brick sitting on my desk.

Overall it could have been much worse, I am going to reach out to the manufacturer and see if they want to be awesome and replace the 980.  They’ll at least reimburse me for the damaged liquid cooler, only had it for ~6 months.  I don’t have high hopes that they’ll reimburse me for the GPU, but I figure it doesn’t hurt to try!

comments powered by Disqus